ActiveMQ Artemis

ActiveMQ's next generation of messaging

ActiveMQ 5.x

Existing 5.x clients can work out of the box. Broker side - we are committed to a migration missing of features based on community driven demand

Existing HornetQ 2.4 and 2.5 clients will also be supported out of the box and also support all of the HA features, The caveat here is for UDP discovery which will need some manual configuration. The User Manual will have more details of this